Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #120 on: November 17, 2018, 03:19:37 AM »
Also NTE326 seems replacement for 2n5461.
As far as I can see I should be able to take out q10 (J201) and get signal through to at least q13 emitter, but nothing on either collector or emitter of q11 yet?
Might change the 2N2222 for 2N5088 and see.
Any comments yet?
« Last Edit: November 17, 2018, 05:00:24 AM by Spencerleehorton »
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!


Rob Flinn

Re: Roger Mayer RM57 build?
« Reply #121 on: November 17, 2018, 05:35:21 AM »
Some thoughts:

It might be useful if you drew out a clear diagram of what you used to design your board.  It's difficult for anyone to check your board when it is not to clear which diagram you based it on, & also that some of the diagrams are little more than a hand sketch.  So your interpretation may be different to mine , for example.

WIth regards to the fet selection.  I'm not sure you can just shove any old n channel fet in there.   If you go back and look at some of Barclaycons posts on pages 3 & 4 of this thread it has a little bit of info.   When you use a fet for compression they use a very small area of the transfer curve of the fet.  Therefore if the fets you are using don't have the right transfer curve compared to what the circuit was designed for you may find that the fet is fully turned on & just shunting your audio signal totally to ground.

Keep up the good work !
« Last Edit: November 17, 2018, 08:23:15 PM by Rob Flinn »
regards Rob

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #122 on: November 17, 2018, 09:00:13 AM »
I have detailed how I’ve done the pcb in a few posts earlier.
But I will put together a new one within some software so it’s easier to read and correct.
The main bones of contention is a few areas in the schematic which are not clear, as you say I may have I interpreted it differently from you!!!
I have ordered some p channel fets so I’ll see how they go but a good bit of discussion about a correct schematic is in order so we are all on the same page
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #123 on: November 17, 2018, 10:40:38 AM »
Ok, i have redrawn schematic, please check and let me know of any errors, i have gone by the hand drawn schematic off the 11 page pdf that was posted.
« Last Edit: November 17, 2018, 11:19:17 AM by Spencerleehorton »
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #124 on: November 17, 2018, 11:24:55 AM »
could someone explain why if i take out the first Jfet (Q10) why i cant get any signal past Q11?
Am i right in saying that signal should appear at Q13 emitter? and branch off at this point to C7 and out to L to go into the Driver Amp section.
I dont understand why the signal ends at the base of Q11? all i see on the scope is a weird shark fin waveform?
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #125 on: November 17, 2018, 12:04:16 PM »
Finally progress, I have signal through the first part of circuit!!
Changed 2n2222 for 2n3391, bingo!!
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

volker

Re: Roger Mayer RM57 build?
« Reply #126 on: November 17, 2018, 12:42:49 PM »
I dont understand why the signal ends at the base of Q11? all i see on the scope is a weird shark fin waveform?

Because Q12 collector isn't connected to R27.

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #127 on: November 17, 2018, 03:58:48 PM »
Lol! Mistake on my drawing!!!
It is connected, will adjust, thanks for spotting that, any other errors?
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Rob Flinn

Re: Roger Mayer RM57 build?
« Reply #128 on: November 17, 2018, 09:24:08 PM »
could someone explain why if i take out the first Jfet (Q10) why i cant get any signal past Q11?
Am i right in saying that signal should appear at Q13 emitter? and branch off at this point to C7 and out to L to go into the Driver Amp section.
I dont understand why the signal ends at the base of Q11? all i see on the scope is a weird shark fin waveform?

Unlikely you'll get much on Q13 emitter becauset here is no way for the signal to appear here because the signal isn't connected to the base of the Q13.  Its base is tied to what I think is +v therefore the transistor is switched on hard.   
regards Rob

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #129 on: November 17, 2018, 11:39:35 PM »
As I said previously that is a mistake, I have corrected, q13 base is connected to q12 collector and R27

see new version below.

Also i now have good signal going through unit to Q1 so the 2N3391 transistors seem good, just need to look at the amp driver section.
My 2N3906 could be duff as i've reused it, waiting on some other info on transistors so hopefully within the next few days will get p-channel jfets and know what transistors to use, so far circuits looks like its close.
« Last Edit: November 18, 2018, 01:00:41 AM by Spencerleehorton »
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!


Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #130 on: November 19, 2018, 03:16:21 AM »
I have all the transistor values now and some little corrections.
Will test this morning and feedback.
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #131 on: November 19, 2018, 05:21:07 AM »
right, just tested and getting good signal through the circuit, i don't have the Jfets in yet so im assuming the waveform looks a bit all over the place due to this?
I replaced all 2N2222 for 2N3391 and replaced the PNP for a BC560C, these are not the correct transistors but what i had to hand just to test the circuit.
Im not out of the woods yet as i wait for the p-channel jfets to install and see what happens with the waveform and the VU meter.
I will update schematic with correct transistor values and post.
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

mig27

Re: Roger Mayer RM57 build?
« Reply #132 on: November 19, 2018, 05:24:00 AM »
Again, thanks so much for sharing your findings!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #133 on: November 19, 2018, 05:31:48 AM »
here we go, so far this seems to be correct, i'll know more like i said once i get those p-channel jfets in there!!!
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

pvision

Re: Roger Mayer RM57 build?
« Reply #134 on: November 19, 2018, 08:00:01 PM »
Watching with interest but not really competent to help! Good work so far, I'd say

It might just serve to confuse but, if you want something to compare against, the Orban 418A is a very well thought-through piece of kit

https://archive.org/details/orban_418A_Manual

Nick Froome

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #135 on: November 20, 2018, 05:57:37 AM »
from what i've read about N-channel vs P-channel Jfet's, the N-channel jfets's are cutting the signal due to positive voltage so closing the gate, if the drain is more positive than the source it turns the jfet on (shuts the gate, cutting signal)

This circuit needs P-channel jfets so if the drain is more negative than the source it will shut the gate, i dont really understand how it goes more negative yet, but perhaps someone could explain?
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #136 on: November 20, 2018, 06:39:39 AM »
Also just to note that I get good signal up till Q1 base, after that it goes screw wiff!!!

Also whenever i connect A100k pot for threshold control waveform comes and goes? when i touch pin 2 the waveform comes back?
Ive checked GND connection and are fine, then when i bypass the A100k pot and connected the wires together it fine?

dodgy pot? i thought so so i tried a couple more, same problem?
« Last Edit: November 20, 2018, 08:10:14 AM by Spencerleehorton »
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #137 on: November 20, 2018, 08:11:26 AM »
ok i have found one problem!! 3.3k at R62 rather than 330R, now i get great waveform at output.

Just need to sort threshold pot and hopefully get these p-channel jfets soon!!

update:

sorted pot problem, must have either been a dodgy wire or could have been my scope playing up!!!
seems fine now apart from i need a new probe!!
« Last Edit: November 20, 2018, 12:00:07 PM by Spencerleehorton »
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

Spencerleehorton

Re: Roger Mayer RM57 build?
« Reply #138 on: November 22, 2018, 07:45:55 AM »
well i seem to have a working compressor!!!

If i can sort out this dodgy batch of A100k pots i should be in business.

I'll start putting in a case now and then test, then take in the studio and do some recording!!!
website: www.mohawkstudios.co.uk
email: [email protected]

If it hisses its probably the wrong impedance!!!
Or a snake!!!

mig27

Re: Roger Mayer RM57 build?
« Reply #139 on: November 22, 2018, 08:45:37 AM »
Congrats!
Please do share some sound samples!


 

Related Topics

  Subject / Started by Replies Last post
4 Replies
2570 Views
Last post February 02, 2006, 04:40:00 PM
by analoguedude
9 Replies
2310 Views
Last post October 22, 2008, 10:27:55 AM
by [silent:arts]
7 Replies
2969 Views
Last post April 09, 2009, 11:22:30 AM
by EmRR
28 Replies
980 Views
Last post May 19, 2019, 05:37:31 AM
by abbey road d enfer