Rochey

Windows XP screwed me again
« on: October 19, 2010, 03:48:32 PM »
Just wanted to share a frustration...

My 3 year old dell laptop started getting slow. really effing slow. I was even getting glitches in music playback. not good when your demo'ing products and using it as a music source!

Looked at the task manager, 40% - 60% idling... but the processes didn't add up to that.

Annoying.

Got a program for free called process hacker.
Turns out, there was a significant amount of hardware interrupts going on in the system. something was causing a TON of interrupts.
An afternoon of googling found this link:

http://forum.sysinternals.com/topic965.html

Turns out, after a number of hibernates etc, XP thinks there's something wrong with the hard disk controller, and switches from DMA mode to PIO mode.
Sounds like it's basically bitbanging the hard-drive, rather than doing clean bulk DMA transfers.

Anyway, I went to device manager, removed the IDE driver and restarted twice.

Seriously. My machine hasn't been this slick/fast in AGES.

Just wanted to share my experience, and hopefully stop someone from throwing their PC out the window!  ;D

/r
Expat Audio Home: http://www.expataudio.com


Re: Windows XP screwed me again
« Reply #1 on: October 19, 2010, 04:22:44 PM »
Yeah, good tip Rochey, happened to me before. Same problem , couldn't get audio to play back etc, comp so so slow. Was like having a new machine afterwards.
Chris

sahib

Re: Windows XP screwed me again
« Reply #2 on: October 19, 2010, 04:54:14 PM »

Good tip. Our home pc with xp was the same. I removed the McAffee and it is as fast as a leopard now.


 

Related Topics

  Subject / Started by Replies Last post
6 Replies
1848 Views
Last post January 21, 2007, 03:32:37 PM
by James HE
Windows 7

Started by Svart Brewery

14 Replies
2270 Views
Last post July 27, 2009, 08:28:18 AM
by simonsez
6 Replies
1566 Views
Last post September 22, 2010, 05:40:57 PM
by dmlandrum
12 Replies
4433 Views
Last post December 13, 2010, 05:36:54 PM
by pucho812