jsteiger

Hey folks, I have just finished up the Pictorial Build Guide for my new style 11 space rack kits. This latest version has LC filtering on the rear of the 9-11 backplane. The filtering is mainly for the new cost affordable switch mode PSU that I just added to the store. PS: there is no harm in using the filtered rack with a linear PSU.

511 Rack Pictorial Build Guide is located here:
http://capi-gear.com/catalog/Build_511_Rack.php

Details and automated checkout can be had here:
http://capi-gear.com/catalog/index.php?cPath=87_89_182

The new VPR Switch Mode PSU can be found here:
http://capi-gear.com/catalog/product_info.php?cPath=87_89_182&products_id=567

Since this is the official support thread, please post all questions, components and/or build problems here. I will do my best to help you get things sorted.





Cheers, Jeff
Visit the CAPI store at http://www.capi-gear.com

CAPI is not affiliated with, endorsed by, or sponsored by API.


keeeth

Hi

I recently got the db25 kit and I put it together last night but it doesn't appear to be working right

I have a pair of diyre colour modules in there and the lights on them just slowly pulse and I don't get any signal. The power supply's blue light comes is on until I plug it into the rack at which point it goes off

I have got a video I can show you but I'm not sure how to post it

Can anyone help?

Cheers
« Last Edit: May 15, 2019, 03:05:22 PM by keeeth »

jsteiger

Hi

I recently got the db25 kit and I put it together last night but it doesn't appear to be working right

I have a pair of diyre colour modules in there and the lights on them just slowly pulse and I don't get any signal. The power supply's blue light comes is on until I plug it into the rack at which point it goes off

I have got a video I can show you but I'm not sure how to post it

Can anyone help?

Cheers
What are the DC voltages in the rack? Its possible you have a backwards capacitor in the backplane filter section.
Visit the CAPI store at http://www.capi-gear.com

CAPI is not affiliated with, endorsed by, or sponsored by API.

Peterson Goodwyn

Hi

I recently got the db25 kit and I put it together last night but it doesn't appear to be working right

I have a pair of diyre colour modules in there and the lights on them just slowly pulse and I don't get any signal. The power supply's blue light comes is on until I plug it into the rack at which point it goes off

I have got a video I can show you but I'm not sure how to post it

Can anyone help?

Cheers

DIYRE support checking in here. Once you've checked the power rails on the rack itself, please check the voltages on the +16v and -16v test pads of the Palette. If the power voltages are fine at the rack but messed up at the Palette test points it could be that something is tripping the fuses F1 and F2 and we need to go searching for a short circuit in your build.