pultec high frequency loss troubleshoot
« on: June 21, 2018, 09:48:01 PM »
hey there,
maybe someone here can give me a hint. i just built a pultec from spare parts i had laying around. its solid state using an api opamp. i did stick to the attached layout.
my frequency response is off. massive high end loss in bypass and eq in mode. the rest of the circuit seems to work as it should.
i did use a 150:600 transformer on the output while the original asks for a 250:600 one. could this cause my issues? or would it only effect my levels? an answer to this would really help me. if i can rule out the transformer, i will have to tripple check the filter section... cheers!


Re: pultec high frequency loss troubleshoot
« Reply #1 on: June 21, 2018, 09:51:39 PM »
ps: please let me know if a wrong value treble boost pot (1k instead of 10k) could cause this as well. my pots are not labeled from the back and already wired.... maybe i messed up.

thanks!

ruffrecords

Re: pultec high frequency loss troubleshoot
« Reply #2 on: June 22, 2018, 08:00:48 AM »
Are you sure the 10pF across the 2520 input is 10pF?

Cheers

Ian
www.customtubeconsoles.com
https://mark3vtm.blogspot.co.uk/
www.eztubemixer.blogspot.co.uk


'The only people not making mistakes are the people doing nothing'

Re: pultec high frequency loss troubleshoot
« Reply #3 on: June 22, 2018, 10:32:33 AM »
Are you sure the 10pF across the 2520 input is 10pF?

Cheers

Ian

Ian how are you! Gosh you‘re the man. Saved my build once again 😀 stupid me misread and inserted 100uf instead of pf. Just wired a 100pf in there and it’s all good now. Sounds unreal. Thanks again!

ruffrecords

Re: pultec high frequency loss troubleshoot
« Reply #4 on: June 22, 2018, 05:56:40 PM »
I don't think you should be soldering in your bare feet!!!

I am pleased to say I am well - thank you for asking. I am making steady progress on the Mark III tube mixer. I just ordered some custom metalwork for it. The first version is going to be an 8ish channel sidecar a bit like the Aurora only sexier.

Cheers

Ian
www.customtubeconsoles.com
https://mark3vtm.blogspot.co.uk/
www.eztubemixer.blogspot.co.uk


'The only people not making mistakes are the people doing nothing'


 

Related Topics

  Subject / Started by Replies Last post
4 Replies
2867 Views
Last post October 11, 2004, 01:51:53 PM
by soundguy
3 Replies
3330 Views
Last post May 13, 2008, 12:45:40 AM
by
2 Replies
1709 Views
Last post June 04, 2009, 11:56:17 AM
by kambo
3 Replies
1377 Views
Last post March 12, 2013, 03:16:07 AM
by ricardo