Poptop U67 repair
« on: August 14, 2018, 09:55:06 PM »
Looking for someone in the US to fix my U67 clone.  It has never worked and has been sitting on
a shelf for a couple of years.  The PSU gives pretty acurate readings but the mic does nothing
tube / heater will not glow. 
I live in near Athens GA.


Re: Poptop U67 repair
« Reply #1 on: November 26, 2018, 12:06:11 PM »
Do you have a DMM or other test equipment?

Tube not lit?  Save yourself some money and trouble first, then repost.

1.  Have you taken an ohmmeter and checked EACH connection of the PSU to mic cable including the shield, looking for incorrect or open connection(s)?
2.  Is the tube OK?  Test the heater pins with an ohmmeter for continuity.
3.  Have you opened the mic and measured for DC heater voltage at the mic end of the power supply cable or preferably, at the mic cable connector or at the base of the tube socket WITH the tube plugged in to load the supply?  (Be careful, HT may be present on nearby tube pins!)  Alternatively, you could substitute a 42 ohm 1 watt resistor for the tube heater for preliminary setup by inserting the resistor leads in pins 4 and 5 to "load" the heater supply to facilitate heater voltage adjustment.
4.  Look CAREFULLY for cold solder connections on the circuit board, tube socket, connector pins, etc.  If you are not sure, resolder all the solder connections carefully.  One bad connection will disable the mic.

Once you get the tube lit, you may be "home free" after verifying the HT voltage is correct.
Good luck...


 

Related Topics

  Subject / Started by Replies Last post
4 Replies
1399 Views
Last post May 04, 2005, 03:49:19 AM
by gyraf
4 Replies
1904 Views
Last post December 08, 2010, 02:11:41 PM
by pittsburgh
8 Replies
2544 Views
Last post November 03, 2011, 01:40:00 AM
by baadc0de
1328 Replies
232319 Views
Last post February 06, 2019, 10:01:14 PM
by Phrazemaster