Khron

Ram Audio S6000 (aka LD Systems SP 6K) woes
« on: June 05, 2019, 03:48:12 PM »
https://khronscave.blogspot.com/2019/05/44-ram-audio-s6000-teardown-repair.html

In the link above is a bit of a "preamble" along with some internal photos of this beastie.

After what's there, the owner (a buddy and neighbour) said the built-in limiter kicked in way too early, along with considerable distortion.

Some further digging revealed that R187 (page 36 of the service manual) had failed open-circuit. Replacing that solved the too-early-limiting, which happened due to half of the channel A output section not actually working.

Trouble is that now, once the output (on BOTH channels, oddly enough) goes above around 3Vpp, the top of the sinewave breaks into some sort of high-frequency oscillation. Which is REALLY strange, if you ask me.

I'd welcome any input any of you brighter-minds-than-i might have  :-\

Attached - a scope shot of the amp output (T7A / T8A) below the oscillation threshold
Khron's Cave - Electronics - Audio - Teardowns - Mods - Repairs - Projects - Music - Rants - Shenanigans


Khron

Re: Ram Audio S6000 (aka LD Systems SP 6K) woes
« Reply #1 on: June 05, 2019, 03:51:22 PM »
And here's a scope shot (same settings, 10:1 probe, same test point) with the volume turned up just a smidge.
Khron's Cave - Electronics - Audio - Teardowns - Mods - Repairs - Projects - Music - Rants - Shenanigans

radardoug

Re: Ram Audio S6000 (aka LD Systems SP 6K) woes
« Reply #2 on: June 05, 2019, 06:50:47 PM »
Could indicate some bypass caps have lost their value.

Khron

Re: Ram Audio S6000 (aka LD Systems SP 6K) woes
« Reply #3 on: June 05, 2019, 07:21:40 PM »
There's not many to speak of, but there are a few small 10u /100V electrolytics across each "section" of power rail (mid-right side, on page 38 of the service manual).

I suppose it can't hurt to swap'em out; i'll just have to see if i have any suitable replacements.
Khron's Cave - Electronics - Audio - Teardowns - Mods - Repairs - Projects - Music - Rants - Shenanigans

Khron

Re: Ram Audio S6000 (aka LD Systems SP 6K) woes
« Reply #4 on: June 07, 2019, 12:29:40 PM »
Swapped out those small caps, but to no avail, oscillation still shows up same as before   :o
Khron's Cave - Electronics - Audio - Teardowns - Mods - Repairs - Projects - Music - Rants - Shenanigans


 

Related Topics

  Subject / Started by Replies Last post
16 Replies
6290 Views
Last post January 26, 2009, 04:01:07 AM
by 1954U1
19 Replies
8935 Views
Last post November 20, 2017, 07:11:43 AM
by analogguru
0 Replies
2952 Views
Last post December 27, 2008, 11:21:53 AM
by luis
4 Replies
1592 Views
Last post January 18, 2010, 08:25:11 PM
by bananamoon