Altec 9475A clone PCBs High Noise- Anyone seen these?

Help Support GroupDIY:

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
I was handed a bunch of these cards (fully assembled) for racking. I have been having trouble finding documentation on them (other than the original 9475A schematics/manual). I know the 9475's were prone to RF killing them if all the grounding wasn't perfect. From what little I've seen these cards are supposed to avoid that... but whoooo boy are they noisy as hell. Staticy whistling like crazy.

All proper grounding procedures on my case have been done- I have RF/RMI filtering on the input xlrs, chassis and 0V are isolated and tied only at the external power supply, Pin 1's all tied right to chassis at input. On the cards, tacking in a cap from 0V to chassis on each card (which was recommended by the seller of the PCB's so says the person who handed them to me) seems to reduce the noise somewhat, but not nearly enough. I've verified this guy assembled them correctly and all parts are correct values etc... and i've isolated with a bench power supply with no change.

Just wondering if anyone has seen these cards or knows anything about them, or if they need some special way to be implemented to work quietly.

IMG_1287.jpeg
 

radardoug

Well-known member
Joined
Oct 10, 2009
Messages
1,125
Location
North New Zealand
You have transformers on input and output, why would you not just earth the 0 volt line? What is the nature of the noise? Hum or hiss?
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
You have transformers on input and output, why would you not just earth the 0 volt line? What is the nature of the noise? Hum or hiss?
Neither. It’s a randomly modulated rising and falling ‘whine’ with some white noise underneath. It’s a HF oscillation basically- but given what i’ve heard about the circuit in general my brain went to RF issues first.

Strapping 0V to chassis ground at the PCB makes no change to the noise, and is louder than with the cap across.

I just feel like the layout is bad, but my guy tells me the dude he got these from built them to replace bad modules in his altec console and did so with the assistance of John Hall…. So if that’s true I have to assume they’ve been made to work effectively for his situation..
 
Last edited:

beatnik

Well-known member
Joined
Oct 18, 2009
Messages
1,011
Location
Dorset, UK
Do you also have noise when the cards are in an earthed metal chassis ? Sometimes even having the top lid open makes the noise worse as crap from lights and other equipment can be picked up.
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
Do you also have noise when the cards are in an earthed metal chassis ? Sometimes even having the top lid open makes the noise worse as crap from lights and other equipment can be picked up.
Yup. I even ground the paint off at panel contact points to get solid, clean, metal to metal contact. Sadly, no difference.
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
Do you have the right grounding on the input and output transformers? Do you have a scope and proper tools?
Yes. And yes, my bench is quite fully equipped.

I've gotten some more insight and dug around the layout a bit more and I'm not convinced these ever worked as advertised. I think the person who did these was- not as skilled as was required.
 

freshtapescent

Active member
Joined
Jan 25, 2014
Messages
28
Although as you said you may be in trouble layout-wise, in my experience the Altec 9470/9475 amps need really well-matched transistors. In high RF environments I’ve often had to leash them above 40kHz or so with input caps. Best of luck.
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
Although as you said you may be in trouble layout-wise, in my experience the Altec 9470/9475 amps need really well-matched transistors. In high RF environments I’ve often had to leash them above 40kHz or so with input caps. Best of luck.
I had begun wondering about this myself after perusing the original schematic. Also Since I didn’t assemble the boards. Your comment makes me even more curious.
I’m gonna grab some spares this morning and get a few tightly matched pairs in there and see if that changes the landscape at all.
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
Ok. It looks like i've got it solved...

Layout seems to not be the issue- but MATCHING also wasn't the issue. Nor grounding, or input RF filtering- My racking and power supply configuration seem to be spot on.

Turns out- at least as much as I can figure- the person who 'designed' these cards chose the wrong transistor sub for the first two stages. The boards were designed for metal can 2N2484's which look like they work on paper, but even when i went back and got VERY tightly matched pairs the 'white noise' component got significantly worse, while the oscillation 'whine' went away completely.

So i decided on a whim to double check the modern cross reference for the 2N3900A, and between some datasheets and a few recommendations i grabbed a pile of 2N5088's. Matched up a bunch of pairs and installed them into a card- and it was so quiet i thought it wasn't turned on.

I swear I said "No way, this must be broken"- but I plugged in a mic and god damn if there wasn't a beautiful amount of quiet gain coming out the ass end of these.

Apparently the 5088 is made with a similar/same process as the 3900A's so it seems like a natural sub. And it was damn easy to find close matches in a batch of 50. The 2484's were much wider in tolerance.

I'm not calling it case closed until I burn this in for a few hours- but it certainly seems to be resolved at the moment!
 

iampoor1

Well-known member
Joined
May 11, 2013
Messages
800
Location
California
I wonder, are the 2n2484s you have counterfeit/bad? Hard to compare the noise figure between the 2n5088 and 2n2484 as they are specified at different collector currents in datasheet (atleast the ones Im looking at hehe)
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
I wonder, are the 2n2484s you have counterfeit/bad? Hard to compare the noise figure between the 2n5088 and 2n2484 as they are specified at different collector currents in datasheet (atleast the ones Im looking at hehe)
Have two different batches- but at least the one batch I have is from a proper dealer. The other is from a local electronics surplus. Same result
With both batches.
 

iampoor1

Well-known member
Joined
May 11, 2013
Messages
800
Location
California
Have two different batches- but at least the one batch I have is from a proper dealer. The other is from a local electronics surplus. Same result
With both batches.
Interesting! I wonder if maybe the collector current/source impedance isnt a good match for the 2n2484s.

Always great to find out that more common parts that are readily avaliable work better. I have loads of 2n5088s and have been curious to try out building some of these :)
 

Whoops

Well-known member
GDIY Supporter
Joined
May 9, 2008
Messages
6,791
Location
Portugal
Just wondering if anyone has seen these cards or knows anything about them, or if they need some special way to be implemented to work quietly.

Those PCB's were offered/sold for the last years in Ebay, there was also the Langevin AM16 version.
I know the person who did (and sold) those PCB's and I have his contact.
PM me in case you want to contact him.

I checked my docs and I don't have any docs on those boards besides the "Parts List".
But I have plenty of Altec 9475 documents in case you need them.
Altec 470A, 475A, 9470A and 9475A are all the same circuit.
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
Ok so i did a bit more experimenting and I'm just convinced that the 2484's aren't the right sub in this circuit.

I tried multiple terminating impedances on the input side, strapping the transformer for 1:5 vs 1:10... nada difference to the noise. I've tried two sets of well matched 2484's, same result. I verified the rest of the circuit values match the original...

5088's? Dead silent in each card. As long as these pass burn-in, I'm calling it solved.
 

Whoops

Well-known member
GDIY Supporter
Joined
May 9, 2008
Messages
6,791
Location
Portugal
On the Altec units the 4x input transistors are 2N3900A an the 2x output transistors are 2N3053
 

amplexus

Well-known member
Joined
Jan 11, 2018
Messages
133
On the Altec units the 4x input transistors are 2N3900A an the 2x output transistors are 2N3053
Yes, I know, I have all the original docs/schems. Which is how I came about to the 5088's for inputs- very similar process and specs to the 3900
 

Latest posts

Top