DBX 166 - How to calibrate it?

Help Support GroupDIY:

smilan

Well-known member
Joined
May 29, 2017
Messages
314
Hi, I have an old DBX 166.
I've modified it (only one channel so far) with the following modifications:
PSU MoD: – Replace c3 ,c4, c7, and c8 with 1000uf-2200uf 35v caps
– Replace c5 and c9 with a .1uf film cap (preferably polypropelene)
– Bypass c6 and c10 with .1uf film caps
Channel 1:

IC MoD: – Replace chip OA1 with better ic (NE5532,) and install a gold plated ic socket.
– Repalce chip OA2 with better ic ( OPA134) and install a gold plated ic socket.
– Replace the VCA IC1 with a THAT 2180AL08-U (lift pin 4, pin 4 should not connect to anything)
– Add a 47pf NPO ceramic cap from pin 3 of OA2 to ground (Suggested by Jim Williams)

Capacitor/resistor MoD:
– Replace c14 with a 22uf 35v bipolar cap
– Bypass that with a .22u film cap
– Note: c14 was originally a 3.3uf cap. You could fit in a film cap in there if you are carefull.
– Replace c25 with a 22uf 35v bipolar cap
– Bypass that with a .22u film cap

– Replace r17 and r18 with 22ohm metal film resistors
– Replace r1 and r4 with 1k metal film resistors
– Replace r3 and r6 with 7.5k metal film resistors
– Replace r2 and r5 with 10k metal film resistors
– Replace r7 and r13 with 2k metal film resistors

IC Control Voltage (Optional) MoD: Turns this compressor into a beast.
– Replace chips OA3, OA4, and OA5 with gold plated ic sockets and a better ic like a LT1124.

No I'm having troubles to re-calibrate it...
I'm following the instructions of the service manual, but on the first step (slow RMS symmetry and level) my scope (Tektronix 2215) is freaking out and shows this thing (which is not even close to the screen shoots that appears on the service manual).

I'm using a Boonton1120 as my tone oscillator.
The output impedance of the 1120 is 600 Ohms instead of 50 Ohms as the service manual request, this mismatch can be the reason for what I'm seeing on the scope or there's something else that might went wrong?
 

smilan

Well-known member
Joined
May 29, 2017
Messages
314
* I couldn't find instructions at the service manual how to set the trim pots before starting to calibrating the unit. Maybe someone can help me with this procedure?
 

Script

Well-known member
Joined
Nov 27, 2008
Messages
1,778
Location
Japan
Maybe on page 16 in pdf you linked to?

Say, what schematics do your mods refer to ? The 166 one in Tech Docs ?
Sure about this part " 47pf NPO ceramic cap from pin 3 of OA2 to ground" ?
 

JohnRoberts

Well-known member
Staff member
GDIY Supporter
Moderator
Joined
Nov 30, 2006
Messages
23,274
Location
Hickory, MS
making that many changes at the same time introduce multiple opportunities for a mistake.

600 ohm source impedance is unlikely to cause problems.

Start from the input and troubleshoot everything you changed.

JR
 

Latest posts

Top