Drip Dual-STA PSU build

Help Support GroupDIY:

morls

Well-known member
Joined
Jul 15, 2013
Messages
163
Location
Australia
Hi there,

I've just finished building the power supply for this project. I followed the errata posted on the Drip site, as well as some new docs posted by Gregory last month updating the info on resistors and fuses. I'm skipping the on-board regulators, and will instead rely on the regulators on each channel. I've really taken my time with this, as 600V makes me very nervous. I thought I'd post pics here, if anyone sees something that looks wrong please let me know!

I haven't figured out whether I need the diodes AND relays on the XLR i/o PCB. Can anyone help?

Next step is saving $$$ for the Sowter transformers. The main boards are done, as well as both control boards, got all the SMA cabling sorted, case is finished, so it's really just tubes, transformers and VU meters now...
 

Attachments

  • PSU1.png
    PSU1.png
    1.3 MB · Views: 35

FarisElek

Well-known member
Joined
Oct 26, 2019
Messages
408
I successfully built this and use it all the time. Your psu looks fine.

Use diodes and relays. The diodes are a precautionary thing. They're not necessary but I'd throw them in there incase you accidentally send phantom into your sta level or something weird. Probably unnecessary but might as well.
 

morls

Well-known member
Joined
Jul 15, 2013
Messages
163
Location
Australia
Thanks for that. Is it 1N4007 diodes?

Did you have to adjust the trimmer resistor next to the voltage regulator? I'm hoping the trimmers on each channel's regulator will take care of any voltage adjustments.
 

FarisElek

Well-known member
Joined
Oct 26, 2019
Messages
408
1N4007 will work great. Once you have the psu hooked up, you adjust the trimmer so that the heater power supply reads 6.3v. That information is definitely on the manual.
 

JMan

Well-known member
Joined
Oct 26, 2019
Messages
312
Location
Chicago
Any advantage to using the regulators on each channel rather than the onboard regulators on the psu?
 

morls

Well-known member
Joined
Jul 15, 2013
Messages
163
Location
Australia
The main reason is to keep the temperature down, which is also why I went with diodes instead of the 5AR4.

Just heard back from Gregory, the diode recommended for XLR i/o board is 1N4148
 

JMan

Well-known member
Joined
Oct 26, 2019
Messages
312
Location
Chicago
morls said:
The main reason is to keep the temperature down, which is also why I went with diodes instead of the 5AR4.

Just heard back from Gregory, the diode recommended for XLR i/o board is 1N4148

Ah, good call. 

Also, what were the new docs that you mentioned that Gregory posted?  With his new website (which is much tidier than the old one), I didn’t think he had the docs linked up yet.

I won’t build this for quite awhile yet, but when folks discuss it, I take notes.  Hoping it will help things go smoothly whenever I eventually get around to it.
 

FarisElek

Well-known member
Joined
Oct 26, 2019
Messages
408
morls said:
The main reason is to keep the temperature down, which is also why I went with diodes instead of the 5AR4.

Just heard back from Gregory, the diode recommended for XLR i/o board is 1N4148

The 1N4007 is over qualified for the job but works. I used them because I had a bunch of them in my drawer.
 
Top