Elab LA2A - Build thread

GroupDIY Audio Forum

Help Support GroupDIY Audio Forum:

Rob Flinn

Well-known member
Joined
Jun 3, 2004
Messages
4,827
Location
Sussex, UK
Rufus said:
I am posting my here to see if someone could help me to bring my Elab La2A kit to life....  every time I turn on the compressor the fuse blow up; I had unplugged the secondaries connection and I even rebuild  the primaries connection out of the box dutch taped the secondaries , and the fuse in the IEC keeps blowing up?  - before paying a professional to check my connections could some one please help me? ...

DO you have a data sheet for the transformer ?  I'm looking at your drawing & looking at the 2 red wires going to the switch it could  be that you have a secondary shorted by doing this, although without the data sheet it is difficult to know.  Please post the data sheet.
 

Rufus

Member
Joined
Jul 6, 2014
Messages
10
Location
Miami
this is all info I could gather from the Antek section (see attached file)...
 

Attachments

  • antek-05t240-50va 240v transformer.png
    antek-05t240-50va 240v transformer.png
    458.2 KB · Views: 17

Rufus

Member
Joined
Jul 6, 2014
Messages
10
Location
Miami
Adam thanks for the information, I will try them out (1A slow blow fuse (as listed in the Opto 6 BoM). I hope this solve my issue, you rock!!!!
 

HP200CD

Member
Joined
Feb 1, 2015
Messages
21
Location
Hudson Falls, NY
Rufus - I had the same problem with the Antek 05T-240 transformer. On the workbench, not connected to anything on the secondaries, it kept blowing the 400mA fuse. I switched to a 1A slow blow (Digikey 507-1246-ND) and the problem was solved. I have not completed my main board yet, so I don't know for sure. I think it has a larger inrush current spike than expected for a 50VA transformer.
 

HP200CD

Member
Joined
Feb 1, 2015
Messages
21
Location
Hudson Falls, NY
I think there is an error in the build doc. On page 14, you mention that C14 is used to boost the high frequency to compensate for the loss of the original transformers, but the photo below shows the IC socket in the C4 position, not in the C14 position. On the 1968 schematic, it looks like this compensation capacitor is also called C4.
 

Attachments

  • C4 socket.png
    C4 socket.png
    732.2 KB · Views: 18

HP200CD

Member
Joined
Feb 1, 2015
Messages
21
Location
Hudson Falls, NY
Almost done. Very nice PCB. Thanks DeepDark for all the work you must have put into this project.
 

Attachments

  • 5F197D70-B565-48BC-8E38-A5F939CA4E5F.jpeg
    5F197D70-B565-48BC-8E38-A5F939CA4E5F.jpeg
    940.5 KB · Views: 38

PedroLaformula

New member
Joined
Mar 13, 2016
Messages
4
Hello everyone, i am trying to contact by mail and mesenger to get 2 pcb LA-2A.
I still haven't received any reply after 3 months.
Can anyone help me or give me some information?
Thank you.
Regards
 
Top