Ensoniq DP/4+ (cap leakage, corrosion)

GroupDIY Audio Forum

Help Support GroupDIY Audio Forum:

eling

Member
Joined
Mar 19, 2022
Messages
10
Location
Hackney, London
I have changed all caps, VRs, and trim pots throughout the unit and the majority of ICs on the analog board. Absolutely no change in behaviour.

Next step... Transistors?
 

Attachments

  • 20220516_111028.jpg
    20220516_111028.jpg
    205.3 KB · Views: 12
  • 20220516_111127.jpg
    20220516_111127.jpg
    205.3 KB · Views: 13

blatboy

New member
Joined
May 8, 2022
Messages
2
Location
NYC
Man do I appreciate this thread. Thank you so much. My board fortunately doesn't seem to have very much corrosion but it's noisyAF. Replacing all the caps now. So far, so good.
 
Joined
Feb 14, 2022
Messages
22
Location
Germany
Man do I appreciate this thread. Thank you so much. My board fortunately doesn't seem to have very much corrosion but it's noisyAF. Replacing all the caps now. So far, so good.
What kind of noise? I had noise after recapping, but it was more kind of distortion... I solved this by adjusting the blue dc offset trimpots.. (can be done for each channel by bypassing the effects) There is a sweatspot for each channel, where the distortion noise is gone.
 

blatboy

New member
Joined
May 8, 2022
Messages
2
Location
NYC
Combination of static, distortion, and audio not sounding like it's coming through clearly... sometimes not even sounding at all. Once I finish with the caps (there's definitely corrosion and all my testing has shown dead caps ) I'll try to tweak those trimpots. Thanks for the hot tip.
 

Latest posts

Top