Mnats 1176 Rev A v1.2 Issues

Help Support GroupDIY:

gg85

Well-known member
Joined
Nov 26, 2008
Messages
94
I built one of these about 10 years ago, it's been my number one since.

Today I dropped in a UTC O-12 and while the lid was off I thought I'd recalibrate everything. I noticed the GR metering is way way way off but it never used to be. It's showing about 12dB compression when in fact the unit is only compressing about 1-2dB, and I can't cal it up.

My guess is that the q12 and q13 2n3707 FETs are the issue (I've been using 3708's), but before I order more and start changing things around I just wanted to get some input from people that know more than me :)

Any help is appreciated!!
 

Whoops

Well-known member
Joined
May 9, 2008
Messages
5,696
Location
Portugal
just to see if I understood correctly, you had it working properly for 10 years but now decided to install an UTC 012 and after that the GR meter is off?
is that right?
 

gg85

Well-known member
Joined
Nov 26, 2008
Messages
94
just to see if I understood correctly, you had it working properly for 10 years but now decided to install an UTC 012 and after that the GR meter is off?
is that right?
Yep that's right! I don't think it has anything to do with the input transformer. It may have been doing it for a while without me knowing.

I swapped the 2N5457's around to see if anything changed on the actually GR side vs what was metering and then recalibrated and it seems to be working fine now, which is very strange. Could've been a possible dry joint on Q11. Hasn't played up since so fingers crossed :)
 
Top