MXR Omni 180 , & HVTP2 preamp schematics

Help Support GroupDIY:

maxwall

Well-known member
Joined
Nov 16, 2004
Messages
1,092
Have a early 80's MXR omni 180 guitar effects rack and pedal board on the bench trying to fixup for a friend, can anyone donate test info or schematics. This has the BBD chips SAD4096 and SAD1024a. Taking a shot it might be something other than the BBD chips. Maybe a bad op amp , comparator or other linear IC. The PSU is at 15 vdc no issues, no obvious shorts in the circuit. The unit passes dry signal but the pedal board switching is not activating all LED's on the rack unit when the pedal board switches are exercised. The LED's on the pedal board do work ok all mechanicals switches are ok. Tested pots & mechanical switches on the rack front panel. All 1/4" input and output jacks are functional and clean. Tested all Electros and Tantalums for ESR and low resistance. Tested and reset all trimmers. The result are no effects heard at any stage. Ultimately if the BBD chips are bad then this unit is electronic waste. There is a service manual online for $20 but I'm going to hold out on that option.

The effects chain as follows : Comp - Distortion - EQ - Delay - Flanger/CH , External Loop with gain control

Here is a list of IC components for Omni 180 :
Opamps : LM1458(x12) , RC4558P(x2), TL072P
Other IC's : NE571N, NE5045N , CA3280E, CA4053BE, CA4013B, LM339N
Transistors : 2N5088 , 2N4126
Reticon Bucket Brigade Chips (BBD) : SAD4096 x1 ( delay ) , SAD1024a x1 ( flanger CH)

Also , looking for a top & bottom snapshot of the pcb for the DIY Hamptone HVTP2 tube preamp kit that was released way back in 2004 . Wanted to build one of these but Hamptone discontinued it. Wanted to do a point to point version as a project. Apparently a lot of these were sold at the time they were offered in kit form. Hamptone offers no support or info on this tube preamp kit. All current website support has broken links and incomplete info. Not sure if a official build guide with schematic was ever released with the kit. I already have the Tape Op article with schematic but I prefer something from the actual build guide as I suspect they may not be like for like.
 

Attachments

  • 8.jpg
    8.jpg
    171.7 KB · Views: 17
  • 5.jpg
    5.jpg
    153.4 KB · Views: 15
Last edited:

NOON

Well-known member
Joined
Nov 25, 2014
Messages
182
Location
Melbourne, Australia
I worked on a phaser pedal that used a SAD1024 chip. Sounds like similar symptoms, no effect. I tried all kinds of things including sourcing and swapping the chip. It turned out that the tuning of the trimmers is very sensitive and fussy, there's a tiny sweet spot combo where it works. I think it was an Ibanez phaser but not 100%, there was a tuning procedure online somewhere.
 

maxwall

Well-known member
Joined
Nov 16, 2004
Messages
1,092
The pedal board switching issue and indicator leds turned out to be a faulty comparator IC (LM339N), part of the switching circuit . the comp , distortion and eq all work now , however the unit is permanently damaged as both obsolete Reticon SAD IC's are bad and will not pass any signal , delay and flanger-chorus are gone for good. Adjusting the trimmers made no difference. All opamps and some other logic IC's were replaced with no change - a lot of component swapping and de-soldering. Advice : don't buy one expecting to fix it as a project. Their are plenty of these units up for sale for several hundred $ that will never work again , don't get lured into buying one.
 
Last edited:

the groke

Member
Joined
Oct 2, 2009
Messages
21
Sell the Omni as fast as you can! Breathed a sigh of relief when mine sold. Time bomb! Schems attached.
 

Attachments

  • MXR Omni 180 Service Manual cl.pdf
    1.5 MB · Views: 5

Latest posts

Top