Philicorda / Farfisa repair - unknown parts

crisotop

Well-known member
Joined
Feb 22, 2007
Messages
706
Location
Linz / Austria
Hi again,

The Philicorda is up and running again (even brought the old spring reverb back to live) - next on the bench is a Farfisa Compact Fast. One oscillator is not working, I found a supsicious part again, but couldn't find any info on that - Looks like a transistor but which model? Any substitutes to recommend?

The part says: "5gs 1w 9810/3 1738"

farfisa.jpg


I've an old and probably rare (fully transistorised) Philicorda Organ on my bench with no sound output. I've traced the fault down to the amplifier section where I suspect the following part:

philicorda.jpg


Is that a voltage regulator? one of them says: "127/1 2 S H" the marked and probably broken one: "132/1 3 N B" (although the lettering isn't the best). The 132 model has roughly 18V on two legs and ~32 on the third connection, whereas the suspicous one outputs 600mV.

Sorry for the maybe stupid question, but I'm still learning - hope you guys can help me out once again ;)

thanks in advance
christoph

 

crisotop

Well-known member
Joined
Feb 22, 2007
Messages
706
Location
Linz / Austria
Uh germanium - should I tell the owner it's broken forever and keep them?  :p

Many, many thanks peter - I'm heading for the next step then...

cheers,
christoph
 

clintrubber

Well-known member
Joined
Jun 3, 2004
Messages
5,935
Location
The Netherlands
Don't despair, (at least for Ge transistors) these are very common types. It's just that they might have died because of something else,
so might go down again.

It's the output-amplifier ? If replacements are not practical, how about ignoring that section & tapping the signal somewhere earlier ?

Good luck,

   Peter


uhhh, I initially misread your reaction - you had some Ge-fraud in mind ?   ;)
 

crisotop

Well-known member
Joined
Feb 22, 2007
Messages
706
Location
Linz / Austria
Peter,

please have a look at the first picture (I updated the first post) - what's that transistors exact type (I think it's a transistor)?

The Philicorda is running, got the faulty Ge's from the UK.

Thanks!
Christoph
 

keefaz

Well-known member
Joined
Mar 27, 2006
Messages
736
Location
Paris (France)
On the first picture, aren't there some whiskers on the solder side (thin metallic hairs) ? Or it is just some dust
 

Terby

Active member
Joined
Jul 25, 2006
Messages
31
Location
Dortmund, Germany
Christoph,

I replaced 2 defective 1W9787 transistors in my Fast5 oscillators with some standard BC NPN's (don't remember the exact type), works like a charm again  ;)

  Andreas
 

crisotop

Well-known member
Joined
Feb 22, 2007
Messages
706
Location
Linz / Austria
Cheers Andreas! I got it working yesterday, the PCB had a thin hairline crack - installed a couple of solder / wire bridges, now the F# is up and running again!

Thanks
Christoph
 
Top