Tungstengruvsten

Service info/schematics for a Roland AP-7 'Jet Phaser'
« on: May 04, 2005, 07:24:25 PM »
Hey guys;

got one of these as a gift in partially working condition....the 'jet' settings work(basically 2 different distortion settings, one trebly/marshall and one thicker one) but nothing on the phaser side works....

Anyone have any docs? Schematic would be amazing...it's in relatively good shape and does pass signal so I have my hopes up....
Is that a real poncho or a Sears poncho?



Tungstengruvsten

Service info/schematics for a Roland AP-7 'Jet Phaser'
« Reply #2 on: May 04, 2005, 10:57:49 PM »
many many thanks!  I googled it to death and didn't find it.... :guinness:
Is that a real poncho or a Sears poncho?

Blue Jinn

Re: Service info/schematics for a Roland AP-7 'Jet Phaser'
« Reply #3 on: June 08, 2012, 02:04:02 PM »
Thread revival. Wondering if Tungstengruvsten had any success in repairing your unit, and the trouble it was having. I have one of these, jet works intermittently, and the phaser is also intermittent, more so, sometimes the jet works w/o the phasing, and then the whole unit will cut out passing only clean guitar signal. I've not done any meaningful trouble shooting yet. I may take apart and clean, it had been sitting around for easily 20 years before being put back into service.

I saw a thread on a stompbox forum that suggested a tantalum cap in front of the FET for a similar problem. I have a rather blurry schematic though.
not my thing. I am here just to unbalance the equation --pucho812

 http://www.bluejinn.org

Blue Jinn

Re: Service info/schematics for a Roland AP-7 'Jet Phaser'
« Reply #4 on: June 11, 2012, 05:50:56 PM »
I took the cover off for a quick look and wiggled a few electrolytics around. None of them seemed "puffy" but now it works OK for a longer period of time. I think I will replace those. Also, I saw a thread about cleaning the contacts, so tonight I'm going to spray some "Blue Shower" (only kind I could find locally) on the switch contacts.
not my thing. I am here just to unbalance the equation --pucho812

 http://www.bluejinn.org

Blue Jinn

Re: Service info/schematics for a Roland AP-7 'Jet Phaser'
« Reply #5 on: June 12, 2012, 08:02:09 PM »
A wire had come loose from the slow/fast switch. Re-soldered that, and sprayed some contact cleaner on the metal parts and pots. Going to give it a few days to dry out, and see if that helped.

not my thing. I am here just to unbalance the equation --pucho812

 http://www.bluejinn.org

Blue Jinn

Re: Service info/schematics for a Roland AP-7 'Jet Phaser'
« Reply #6 on: June 15, 2012, 02:21:51 PM »
Another follow up. Cleaned the contacts on the switches, potentiometers and resoldered one connection. That seems to have cured the ills... for now
not my thing. I am here just to unbalance the equation --pucho812

 http://www.bluejinn.org


 

Related Topics

  Subject / Started by Replies Last post
39 Replies
8459 Views
Last post June 06, 2009, 10:35:07 PM
by 1954U1
2 Replies
1519 Views
Last post February 20, 2010, 10:17:23 AM
by substitute
10 Replies
2055 Views
Last post August 25, 2011, 12:08:01 PM
by okgb
0 Replies
499 Views
Last post December 22, 2018, 03:43:15 PM
by shot