MOTU MTP AV repair.
« on: September 02, 2018, 10:17:52 PM »
I've got a MOTU MTP AV that's acting up.  It currently successfully boots about half the time.  Sometimes it powers up to a blank screen (no boot), sometimes it boots up fully, sometimes it boots up, but loses it's memory.  Occasionally it will boot up but will have the wrong data in the screen.

It appeared that the main electrolytic leaked, so I've cleaned the board and replaced the electrolytics.  The 5V rail looks solid and clean.  I have another working MTP AV and have compared voltages and noise levels across the two units, even swapped the MCU's and a couple of other chips.  The problem stays with the "bad" MTP AV.

At this point I'm suspecting the SRAM chips.  These are listed as 68AF031, but I can't find a datasheet for these.  I can find some replacements on ebay from Chinese sellers, but I'm a bit uneasy about going that route.  Does anybody have a datasheet for the 68AF031 or know of a compatible chip?  Would a 62256 work?

Thanks!


Re: MOTU MTP AV repair.
« Reply #1 on: September 02, 2018, 11:01:41 PM »
Ah ha...So the part number is actually M68AF031 and I can find those.

And to answer my own question...No...The 62256 is not pin compatible.  (Bummer because they're cheap.)


 

Related Topics

  Subject / Started by Replies Last post
22 Replies
9299 Views
Last post August 12, 2012, 08:35:16 PM
by mikeyB
1 Replies
1236 Views
Last post May 17, 2011, 11:36:37 PM
by ricardo
0 Replies
1015 Views
Last post May 18, 2011, 02:04:52 PM
by ricardo
9 Replies
459 Views
Last post September 11, 2019, 06:16:50 AM
by Khron